The planned maintenance at Interxion has been completed. The works have identified the need for additional remedial work, which will be carried out during future maintenance windows. Further maintenance windows will be posted once these are scheduled.
Posted Oct 14, 2025 - 11:34 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 14, 2025 - 09:00 UTC
Scheduled
A third party will be performing maintenance on our London fibre ring between 09:00 and 11:00 UTC (10:00 - 12:00 BST) on Tuesday 14th. This work involves cleaning and testing fibre connectors at the IXN (Interxion) site, which will temporarily affect the fibre leg between Volta (Great Sutton Street) and Telehouse North.
To avoid unnecessary route flapping, the affected link will be taken out of service in advance and restored once the work is complete. The other direction in our London ring, as well as other redundant paths, will remain operational throughout. Connectivity will therefore be considered at risk but expected to remain available.
Posted Oct 10, 2025 - 10:56 UTC
This scheduled maintenance affected: Availability Zones (London).