CDRs in Portal/API
Incident Report for Simwood
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 03, 2018 - 08:04 UTC
Monitoring
This is now complete, and CDRs for March should now be available via the portal and API.

We’re continuing to monitor this closely but are confident the CDRs will now accurately reflect your calls for March.

Thanks again for your patience
Posted 5 months ago. Mar 31, 2018 - 17:39 UTC
Update
Unfortunately this was not completed as expected, were continuing to work to resolve this as soon as possible.

Again, billing and calls are not affected, only the display or retrieval of CDR data in the portal or via the API

Please accept our apologies for any inconvenience this causes.
Posted 5 months ago. Mar 30, 2018 - 23:21 UTC
Update
Once again, we apologise for any inconvenience in the delay to your CDRs. This index is rebuilding and we expect it will be complete by 2000 on 2018-03-30.

Until this time CDRs and reports via the API and Portal may be incomplete. Once again, this solely affects the view of CDRs via the portal and API, this interface is entirely disconnected from our billing platform and all calls are being billed as normal, and your balance will reflect this.
Posted 5 months ago. Mar 29, 2018 - 22:19 UTC
Identified
You will notice CDRs and analysis in the portal and API are not totally complete for March.

The view of calls you see in the portal and API is based on an index, which is populated _after_ our billing has taken place, to enable easier querying of CDRs and to produce the reports offered by our API rapidly.

This also ensures that our billing databases, and transactional information, is segregated entirely from the externally-accessible API for security and ensures that heavy querying of the API cannot affect billing.

This index is corrupted and, after a few days battling with it, we have taken the decision to rebuild it entirely.

In all cases these calls have been billed correctly, and your balance will reflect this, but some CDRs may not be visible, nor included in reporting whilst we resolve this.

Thank you for your patience.
Posted 5 months ago. Mar 29, 2018 - 09:48 UTC