Operations Desk - Adverse Weather
Incident Report for Simwood
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 02, 2018 - 20:06 UTC
Identified
Due to adverse weather affecting the area around our Bristol offices, and the continuing advice not to travel, the majority of our Operations Desk team will not be in the office today, Friday 2nd March.

We would therefore ask that you raise a ticket via https://support.simwood.com/ or by eMail to team@simwood.com rather than calling us unless absolutely necessary.

We apologise for any inconvenience this may cause, however the safety of our team is of the utmost importance.

Thank you for your understanding.
Posted 7 months ago. Mar 02, 2018 - 08:37 UTC